ハード関係の最近のブログ記事

LPM問題(うちのはSillicon Power製)

 うちのWindowsマシン(FMV D751/D)だがWindows10にしてからどうも調子が悪かった。
これまで再インストール3回ほど。
今日もまた再インストールしたが、徐々にファイルが壊れる感じ。
観察すると、なぜかいつもDisk使用率100%ではりついている。
調べるとLPM問題かもとなった。
よく報告されているのはCrucialのSSD、うちのはSilliconPower。
デバイスを調べるとSPCC Solid DiskB28 ATA Device、E20シリーズかな。
ファームウェアもあるのだが、とりあえずLPMチェッカーを使ってみた。
するとうちのSSDはHIPM、DIPMどちらも非対応とのこと。これだ原因かぁ。
ということで、このツールで「AHCI Link Power Management」が表示されるように修正、そしてActiveにしたところ、使用率が下がった。
詳しくはこちらを参照。
http://eeepc.dnki.co.jp/?eid=1106859

 先駆者に感謝!

CanonプリンタMP980の設定

 CanonプリンタMP980の設定ではまったのでメモしておく。

目的
 大学の教育用ネットワークセグメントに繋げたCanonプリンタMP980への設定
(固定IP(同一セグメント)環境、対象はWindows7,8マシン)

必要なもの
 CanonのサイトにあるドライバのうちPIXUS MP980 MP Driver Ver. 1.03とIJ Network Driver Ver. 2.5.7 / Network Tool Ver. 2.5.7
(MP980 ミニマスターセットアップ Ver.1.04はだめなんです)

方法
 1:PIXUS MP980 MP Driver Ver. 1.03をインストール
   なんやかんやいってくるが、とりあえずは適当に完了させる
   →これでプリンタドライバが入る
 2:IJ Network Driver Ver. 2.5.7 / Network Tool Ver. 2.5.7
   なんやかんやいってくるが、自動検出で該当のプリンタを表示させたらオッケー
   うまくいかない時は「デバイスの追加」で行きましょう
   →これを入れないと通信のためのポート「Canon BJNP Port」が入らない
    (ここではまった)

ここら辺が参考かな?
 手伝ってくれたM2のH君K君に感謝。

 Xserve (Early 2008) をご好意でお譲りいただいた。
せっかくなのでMavericksのインストールをと考えたのだが、対応しない機種とのこと。
EFIは64bitだから何とかなるはずと、Mac miniにLionを入れた時のような勢いに任せて情報を探すとありました。
Mavericks on unsupported 2008 Xserve
おお、ほぼ一緒のやり方ね。
0:Xserveへディスプレイとキーボード、マウスを付けてインストールした
1:まずは手持ちのMavericksインストール可能Mac miniにて手持ちUSBメモリ(16gbを使用、8gbでもいけそう)へインストール→再起動せずに終了(再起動しはじめたらUSBを素早く抜く)
2:いったんMac mini内蔵HDDより起動
3:MavericksをインストールしたUSBを刺して、中にある
/System/Library/CoreServices/PlatformSupport.plist
へ追記(テキストエディタでもvimでもお好きな方で)
----(追記内容)----
Mac-F42289C8
Xserve2,1
----(ここまで)----
上記をそれぞれふさわしい場所へ入れる。
Mac-F42289C8だけで良いようだが、いちおうおまじないで)
→作業後USBメモリを外す。
4:USBメモリをXserveに取り付け、そこから起動(ここが結構厄介、command+option効かない。のでいったん内蔵HDDを全て外してUSB起動してから付けた)
→きちんと3の書き換えができていれば起動する。できていないと起動すぐのグレー画面にて駐車禁止マークが出て起動しません。
5:起動したら、オッケーです。
注意点として、OSXのアップデートをかけるとPlatformSupport.plistが書き変わることがあるので、USBメモリはきちんと手元に持っておきましょう。また、PlatformSupport.plistのコピーを保存しておくと良いです。(いちおうUSBメモリの/System/Library/CoreServices/PlatformSupport.plistに入っているはずですが、忘れてしまいますよね。)

 なお、なぜ対応機種から外れたかと言うと、グラフィックボードの問題のようです。
Xserve (Early 2008):ATI Radeon X1300 PCI Expressグラフィックボード内蔵(64MB GDDR3メモリ、シングルリンクMini DVIポート)
Xserve (Early 2009):NVIDIA GeForce GT 120グラフィックカード(256MB GDDR3メモリ搭載)、Mini DisplayPort出力
確かに動作させると、アクセラレーションが効かず、げんなりします。
→こういう場合はWindows用のビデオカードを刺しましょう。私は手持ちのNVIDIA GeForce 8500 GT 256 MBをPCI-Expressスロットに刺しました。GeForce GT 120や220,Radeon HD5770などは行けるようです。起動時のリンゴマークなどは見えませんが起動さえしてしまえば、問題ありません。なお内蔵ビデオは特殊で、ディスプレーを繋げてなくとも1024x768が繋がっていると認識しています。

 SATAのHDDも3台はいるので勇んで手持ちを繋げたところ認識せず。Xserveは昔なつかし(SCSIの頃だなあ)のアップル純正HDD縛りがあるとの記述もあったが、そんなことはないだろうと試したところ、どうやらSATA1.5G転送速度にしないと認識しないよう。WDの320G SATAのジャンパ5-6を繋いで確認したところ、見事認識。(1TBは手持ちではだめだった)

----(追記140625)----
1GBのHDDだがWestern DigitalのWD10EZRXであった。こいつAdvanced Formatなのね。
ということで、この機能を消すべくJP7-8及び3G転送固定のため5-6を繋いだところ、認識してくれた。ちょうどTimeMacineのHDD容量が足りなくなっていたので助かった。

 現在Mavericks+OSXServerを入れてTime Machineサーバとなってます。
機会をお作りいただいたDynaさん、お譲りいただいた滋賀のFさん、先駆者のみなさんに感謝。

MacbookProスワップ

 某所で廃棄になったMacbookPro15(Early2006)、しばらく使えてたもののグラボが壊れて、リフロー失敗、メモリも溶かしてへこんでたけど、やはり某所で同(Late2007)を入手(876円也)。こいつはぼこぼこ、キー取れ、LCD割れで起動確認できずだった。下記のように移植したら動いたよ。にしてもEarly2006とLate2007でずいぶんと違うのね。

・ロジックとボトムケースはEarly2006
・キーボードというかUpperケースはEarly2006,ただしケーブル類とBluetoothはLate2007より移植
→右奥から2番目のネジ止め部分はFirewireコネクタと干渉のためねじ切りました。またタッチパッド裏側にあるプラスチックのスペーサー(灰色2カ所)も邪魔なので取り除きました。
・LCDはEarly2006,ただしiSightとケーブル類とインバーターは交換
(そもそもEarly2006は冷陰極管、Late2007はLCDバックライトなのだが、設計が良いことに、ケーブルアサインがインバーターとLCDバックライト駆動回路で何と同じだったようだ。コネクタ含めうまくスワップできた。)
・ドライブはEarly2006,ただし接続ケーブルは交換
(ケーブルを交換しないと動かず。おそらくIDEなのでケーブルセレクトとかマスターとかスレーブの関係っちゃうかな)

 ということで冷陰極管LCDのMacbookPro15インチ(Late2007)という多分世の中で1台しかないだろうものに仕上がった。こいつはMavericksインストールできるのね。早速家でのお仕事マシンになる予定。

 研究室に某所よりPerseptive Biosystems (Applied Biosystems) Cytofluor 4000 が届いた。
残念ながら故障していたので修理をすることに。
ステッピングモーターが壊れていたのだが、調べてみると、Lin Engineeringの4018S-18-05-4V0.9Aという規格のよう。
P1010372.JPG
バイポーラタイプで4線出てるのね。
うーん、ステッピングモーター高いなーと見ていたところ、秋月のが使えそうとわかる。
700円か、安、ということで購入。
あとは結線だが、図面とにらめっこして次のようにした。
コネクタ側---モーター側
緑---赤
黒---黄
青---青
赤---橙
P1010370.JPG
最初はPhaseに合わせてやってみたけど逆回転になったので、図面の位置関係をもとに合わせた。
これで取りあえず問題なく動作するようになった。
 さて、プーリーを付けようとしたが、0.2 mm太かったのでヤスリで削った。
削る際はカスが本体に入らぬよう、軸を下にして削ろう。
大きさを確認しつつ、入るところまで確かめたら固定用ネジを締める。
軸が若干短いが、何とかギリ収まった。

 なおこの機械、全て同じ規格のステッピングモーターが使われている。
(プレートのX・Y方向に1個ずつ,励起・蛍光フィルター回転用に1個ずつ)
ということで、他が壊れたも応用できると思っている。

 ずいぶん古い機械で、色々なところで廃棄になっているようだが、うちではまだ現役で使うことに。

APC互換バッテッリー情報

 最近APCのUPSのバッテリー交換が頻繁に来るので、メモ。

○Smart-UPS 500 (SUA500JB) / 750(SUA750JB)
純正型番 RBC48L(単体電池2個を1パック)
電圧・容量:24V 7.2Ah(2個)

○Smart-UPS 1000 (SUA1000JB)
純正型番 RBC6L(単体電池2個を1パック)
電圧・容量:12V 6Ah(2個)

○Smart-UPS 1500(SUA1500JB)/Smart-UPS XL 500(SUA500XLJ)
純正型番 RBC7L(単体電池2個を1パック)
電圧・容量:12V 12Ah(2個)

○ES350/ ES500/ ES550
純正型番 RBC2J(単体電池1個)
電圧・容量:12V 7.2Ah

○BK350J/ 500JS
純正型番 RBC2J(単体電池1個)
電圧・容量:12V 7.2Ah

○Smart-UPS 500 (SU500J)
純正型番 RBC20J(単体電池2個を1パック)
電圧・容量:12V 5Ah(2個)

○Smart-UPS 700(SU700J)
純正型番 RBC5J(単体電池2個を1パック)
電圧・容量:12V 9Ah(2個)

○Smart-UPS 1400(SU1400J)
純正型番 RBC7L(単体電池2個を1パック)
電圧・容量:12V 20Ah(2個)

12V 7〜9Ah はサウンドハウス(うちでは立替払可)が、その他はアマゾンのバイクパーツセンター(うちでは立替払可)が安いかな。

識者の方に感謝

Vaioのドライバ関係fromヨーロッパ

 某所で廃棄になったVGN-BX96PS、ドライバがないので困っていたら、ここのが使えるかもということで情報を載せておく。
ftp://ftp.vaio-link.com/pub/VAIO/ORIGINAL/

先人に感謝。
http://mimumimu.net/blog/2010/07/03/vaio-vgn-sz93ns-x64-化計画。/

研究科ポスタープリンタPX-9000使い方

 研究科で管理しているPX-9000の使い方をまとめました。
○利用マニュアル

Terastation Pro (ts-htgl/r5)のリカバリ

 某所にてts-htgl/r5を2台、hs-dhtgl/r5を1台手に入れる。予想通りHDDはなし。
先人の力を借りることに。

症状:TFTP MODE E06 Lost boot imageが表示される。

0:ノートパソコンと該当のTerastationを準備
(ノートの方があとで有線つなげる時に便利)
1:ノートパソコンで、バッファローのウェブよりファームウェアをダウンロード
http://buffalo.jp/products/catalog/storage/hs-dhtgl_r5/
2:ノートパソコンで、ファームウェアを実行(解凍)、実行後にできるinitrd.imgをinitrd.img.zipと名前変更。その後に解凍する。
するとinitrd.buffaloができる。これを適当なフォルダに置く。
(このときパスワードが必要となるがウェブで調べてね(検索ワードはinitrd.buffalo、パスワードぐらいかな))
3:ノートパソコンで、ファームウェアを実行時にできるUimage.buffaloも上記と同じフォルダに入れる。
4:ノートパソコンで、フリーソフトTFTPDをダウンロード
http://www.startupgao.net/soft/tftpd.html
 解凍、起動すると右下に常駐している。
右クリック→設定にて
  ・ルートパスを上記initrd.buffaloとUimage.buffaloを入れたフォルダに設定
  ・その他の項目に下一つ以外(自動的に起動以外)全部チェック入れる(うちではチェック入れないとうまくいかず。)
  ・ノートパソコンのネットワーク設定、IPアドレスを192.168.11.1,ネットマスクを255.255.255.0に設定。(他は空白で問題無し)
5:ノートパソコンとTerastation Proを有線ネットワークで接続。
6:Terastation ProにHDD4台入れて起動ー>エラーが出るのでうるさいからDISPLAYボタンを押してとりあえずおとを止める。表示は「TFTP MODE E06 Lost boot image」となる。
(HDDを電源投入後に入れないとトラブル起こる。詳しくは下記)
7:おそらく右下の常駐しているTFTPDから転送中の吹き出しが出てくる。これが出ればまずはオッケー。
ただし短時間に何回も転送開始、終了を繰り返すようなら、TFTPDの設定を見直すこと。
(これではまった。)
8:うまくいくと10分以上かかるが、Terastation Proが立ち上がる。この時音が出る。
9:ノートパソコンで、バッファローのウェブよりダウンロードしたファームウェア内にあるTSUpdataを起動、ファームウェアをアップデートする。
(今回は1.35でやったが問題無し。はまった点として、Terastation ProにHDDが1台しか入ってないとファームウェアアップデートでACP_STATE_FAILUREが出てアップデートできず)
10:あとは指示に従って再起動したらおしまい。

先人に感謝。
参考サイト
http://nagou.cocolog-nifty.com/haley/2007/12/tftp_d068.html
など

 表記の件、定着機付近で紙がしわくちゃに折れている場合の対策。
原因は定着機から出てきた紙を送るゴムローラーの劣化。
さわって表面がつるつるしてたらダメです。
(メーカーに確認した所、この部分を固く絞った雑巾で拭いてダメなら修理ですと言われた。
確かに拭いてすぐは良いのだけど連続2枚、3枚印刷するとダメになる。
さらにたっぷり水をつけてやるほど効果大だった。)

 対策として、ローラー部分にビニールテープを巻いてやりました。厚みが増して表面抵抗も増します。実は過去にLP-320でも紙送り対策でやりました。

下図はLP-9800C(白いローラー部分が今回の箇所)
P1000552.JPG

下記は下図はLP-9000C(白いローラー部分が今回の箇所),LP-9000Bも多分同じ
P1000553.JPG

Twitter


過去記事(月別)